summaryrefslogtreecommitdiffstats
path: root/test/Makefile
diff options
context:
space:
mode:
authorLukas Fleischer <lfleischer@archlinux.org>2016-09-20 20:53:44 +0200
committerLukas Fleischer <lfleischer@archlinux.org>2016-09-29 22:07:24 +0200
commit49c7e53572be8be7848ff99aa5e60ffd4dc316eb (patch)
tree6e198cd8171f3f8c267fcb9c0acaf4b464c0dcce /test/Makefile
parent1a999810e3a6da21181c91f6b383f69db399cf1c (diff)
downloadaur-49c7e53572be8be7848ff99aa5e60ffd4dc316eb.tar.gz
aur-49c7e53572be8be7848ff99aa5e60ffd4dc316eb.tar.xz
Reorganize tests
Move and rename the existing git-interface tests such that tests for other scripts can be added easily. In particular, the following changes are made: * Move the existing tests from git-interface/test/ to test/. * Rename t0001-auth.sh to t1100-git-auth.sh. * Rename t0002-serve.sh to t1200-git-serve.sh. * Rename t0003-update.sh to t1300-git-update.sh. Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
Diffstat (limited to 'test/Makefile')
-rw-r--r--test/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/Makefile b/test/Makefile
new file mode 100644
index 00000000..d6f0f740
--- /dev/null
+++ b/test/Makefile
@@ -0,0 +1,11 @@
+T = $(sort $(wildcard t[0-9][0-9][0-9][0-9]-*.sh))
+
+check: $(T)
+
+clean:
+ $(RM) -r test-results/
+
+$(T):
+ @echo "*** $@ ***"; $(SHELL) $@
+
+.PHONY: check clean $(T)