summaryrefslogtreecommitdiffstats
path: root/web/html/pkgsubmit.php
diff options
context:
space:
mode:
authorpjmattal <pjmattal>2005-06-23 15:02:29 +0200
committerpjmattal <pjmattal>2005-06-23 15:02:29 +0200
commit4666bd8307a5b2716d6e82c3bd47dcd12994b092 (patch)
tree48d6a9b641eea637e379a6a03a5ac598c02c2735 /web/html/pkgsubmit.php
parent422864112da9909d1218aabf4e24ed33d95d38da (diff)
downloadaur-4666bd8307a5b2716d6e82c3bd47dcd12994b092.tar.gz
aur-4666bd8307a5b2716d6e82c3bd47dcd12994b092.tar.xz
added patch from Jurgen (thanks!)
Diffstat (limited to 'web/html/pkgsubmit.php')
-rw-r--r--web/html/pkgsubmit.php4
1 files changed, 2 insertions, 2 deletions
diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php
index 560d972d..ca1bf9f2 100644
--- a/web/html/pkgsubmit.php
+++ b/web/html/pkgsubmit.php
@@ -164,8 +164,8 @@ if ($_COOKIE["AURSID"]) {
}
}
- $shcmd = "/bin/sh -c 'mv ".$upload_file." ".$INCOMING_DIR.$pkg_name;
- $shcmd.= "/".$_FILES["pfile"]["name"]."'";
+ $shcmd = "/bin/mv ".$upload_file." ";
+ $shcmd.= escapeshellarg($INCOMING_DIR.$pkg_name."/".$_FILES["pfile"]["name"]);
@exec($shcmd);
# if no error, get list of directory contents and process PKGBUILD