summaryrefslogtreecommitdiffstats
path: root/web/html
diff options
context:
space:
mode:
authorCallan Barrett <wizzomafizzo@gmail.com>2008-01-10 03:15:55 +0100
committerDan McGee <dan@archlinux.org>2008-01-20 07:21:19 +0100
commitce225727f67f5b65b5f92ec96b074712c290ea63 (patch)
tree7bc1191180a5bc4ec2f52adb1b0fa5d074d14910 /web/html
parent8c94552042115d2a7bb04de3b4f66cdf95f2a5de (diff)
downloadaur-ce225727f67f5b65b5f92ec96b074712c290ea63.tar.gz
aur-ce225727f67f5b65b5f92ec96b074712c290ea63.tar.xz
Bug in uploading PKGBUILDs and aur schema
This fixes a bug where TUs and devs couldn't upload packages because the query would have an extra column in it to mark the pkgbuild safe automatically, guessing it got missed when the safe flags were removed. Also fixes a screw up I made with the schema file when I added the tables for the voting app. Signed-off-by: Callan Barrett <wizzomafizzo@gmail.com>
Diffstat (limited to 'web/html')
-rw-r--r--web/html/pkgsubmit.php3
1 files changed, 0 insertions, 3 deletions
diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php
index 9bed3f59..46b78cf4 100644
--- a/web/html/pkgsubmit.php
+++ b/web/html/pkgsubmit.php
@@ -486,9 +486,6 @@ if ($_COOKIE["AURSID"]) {
$q.= mysql_real_escape_string($new_pkgbuild['pkgdesc'])."', '";
$q.= mysql_real_escape_string($new_pkgbuild['url']);
$q.= "', 2, ";
- if (account_from_sid($_COOKIE["AURSID"]) == "Trusted User" || account_from_sid($_COOKIE["AURSID"]) == "Developer") {
- $q.= "1, ".uid_from_sid($_COOKIE["AURSID"]).", ";
- }
$q.= "UNIX_TIMESTAMP(), ";
$q.= uid_from_sid($_COOKIE["AURSID"]).", ";
$q.= uid_from_sid($_COOKIE["AURSID"]).", '";