summaryrefslogtreecommitdiffstats
path: root/web/template/pkg_details.php
diff options
context:
space:
mode:
authorLukas Fleischer <archlinux@cryptocrack.de>2010-10-06 04:25:53 +0200
committerLoui Chang <louipc.ist@gmail.com>2010-11-10 20:50:35 +0100
commiteda713032ce9bed773b6c927b2f6ac4b445fe577 (patch)
tree8091bc77f982d2d71a50dcd7b1facdd50a3f14c3 /web/template/pkg_details.php
parentdbb8bb783f2f22b68ad2d65f020390428e77c479 (diff)
downloadaur-eda713032ce9bed773b6c927b2f6ac4b445fe577.tar.gz
aur-eda713032ce9bed773b6c927b2f6ac4b445fe577.tar.xz
Add timestamp when a package is flagged out-of-date (FS#20848).
Signed-off-by: Loui Chang <louipc.ist@gmail.com> - resolve conflict and omit i18n changes.
Diffstat (limited to 'web/template/pkg_details.php')
-rw-r--r--web/template/pkg_details.php5
1 files changed, 3 insertions, 2 deletions
diff --git a/web/template/pkg_details.php b/web/template/pkg_details.php
index 30d17e17..a4b8f954 100644
--- a/web/template/pkg_details.php
+++ b/web/template/pkg_details.php
@@ -35,6 +35,7 @@ $license = empty($row['License']) ? $msg : $row['License'];
# Print the timestamps for last updates
$updated_time = ($row["ModifiedTS"] == 0) ? $msg : gmdate("r", intval($row["ModifiedTS"]));
$submitted_time = ($row["SubmittedTS"] == 0) ? $msg : gmdate("r", intval($row["SubmittedTS"]));
+$out_of_date_time = ($row["OutOfDateTS"] == 0) ? $msg : gmdate("r", intval($row["OutOfDateTS"]));
?>
<div class="pgbox">
@@ -69,8 +70,8 @@ $submitted_time = ($row["SubmittedTS"] == 0) ? $msg : gmdate("r", intval($row["S
print "<a href='$urlpath.tar.gz'>".__("Tarball")."</a> :: <a href='$urlpath'>".__("Files")."</a> :: <a href='$urlpath/PKGBUILD'>PKGBUILD</a></span>";
}
- if ($row["OutOfDate"] == 1) {
- echo "<br /><span class='f6'>".__("This package has been flagged out of date.")."</span>";
+ if ($row["OutOfDateTS"] !== NULL) {
+ echo "<br /><span class='f6'>".__("This package has been flagged out of date.")." (${out_of_date_time})</span>";
}
?>
</p>