summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--support/schema/aur-schema.sql2
-rw-r--r--web/html/index.php37
-rw-r--r--web/html/packages.php49
-rw-r--r--web/html/pkgsubmit.php8
-rw-r--r--web/lib/pkgfuncs.inc83
5 files changed, 2 insertions, 177 deletions
diff --git a/support/schema/aur-schema.sql b/support/schema/aur-schema.sql
index 97828fce..c1697f9a 100644
--- a/support/schema/aur-schema.sql
+++ b/support/schema/aur-schema.sql
@@ -123,8 +123,6 @@ CREATE TABLE Packages (
SubmitterUID INTEGER UNSIGNED NOT NULL DEFAULT 0, -- who submitted it?
MaintainerUID INTEGER UNSIGNED NOT NULL DEFAULT 0, -- User
AURMaintainerUID INTEGER UNSIGNED NOT NULL DEFAULT 0, -- TU/Dev
- Safe TINYINT UNSIGNED NOT NULL DEFAULT 0, -- verified to be safe?
- VerifiedBy INTEGER UNSIGNED NOT NULL DEFAULT 0, -- who verified?
FULLTEXT (Name,Description),
PRIMARY KEY (ID),
UNIQUE (Name),
diff --git a/web/html/index.php b/web/html/index.php
index b379d4d1..854c32c0 100644
--- a/web/html/index.php
+++ b/web/html/index.php
@@ -210,11 +210,6 @@ $result = db_query($q, $dbh);
$row = mysql_fetch_row($result);
$update_count = $row[0];
-$q = "SELECT count(*) FROM Packages,PackageLocations WHERE Packages.LocationID = PackageLocations.ID AND PackageLocations.Location = 'unsupported' AND Packages.Safe = 1";
-$result = db_query($q, $dbh);
-$row = mysql_fetch_row($result);
-$safe_count = $row[0];
-
# Added the user statistcs.
# Added by: dsa <dsandrade@gmail.com>
$user = username_from_sid($_COOKIE["AURSID"]);
@@ -270,30 +265,6 @@ if (!empty($user)) {
print "</td>";
print "<td class='boxSoft'><span class='f4'>$flagged_outdated</span></td>";
print "</tr>";
-
- # Number of safe packages
- print "<tr>";
- print "<td class='boxSoft'>";
- if ($atype == 'Trusted User' || $atype == 'Developer') {
- $q = "SELECT count(*) FROM Packages,Users WHERE Packages.Safe = 1 AND Packages.VerifiedBy = Users.ID AND Users.Username='".mysql_real_escape_string($user)."'";
- $result = db_query($q, $dbh);
- $row = mysql_fetch_row($result);
- $flagged_safe = $row[0];
-
- print "<span class='f4'>".__("Flagged as safe by me")."</span>";
- }
- else
- {
- $q = "SELECT count(*) FROM Packages,Users WHERE Packages.Safe = 1 AND Packages.MaintainerUID = Users.ID AND Users.Username='".mysql_real_escape_string($user)."'";
- $result = db_query($q, $dbh);
- $row = mysql_fetch_row($result);
- $flagged_safe = $row[0];
-
- print "<span class='f4'>".__("Flagged as safe")."</span>";
- }
- print "</td>";
- print "<td class='boxSoft'><span class='f4'>$flagged_safe</span></td>";
- print "</tr>";
print "</table><br />";
}
@@ -315,13 +286,6 @@ print "</tr>";
print "<tr>";
print "<td class='boxSoft'>";
-print "<span class='f4'>".__("Packages in unsupported and flagged as safe")."</span>";
-print "</td>";
-print "<td class='boxSoft'><span class='f4'>$safe_count</span></td>";
-print "</tr>";
-
-print "<tr>";
-print "<td class='boxSoft'>";
print "<span class='f4'>".__("Packages in [community]")."</span>";
print "</td>";
print "<td class='boxSoft'><span class='f4'>$community_count</span></td>";
@@ -356,6 +320,7 @@ print "</tr>\n";
print "</table>\n";
echo "</div>\n";
# End Table 1
+echo "<span class='f4'>".__("DISCLAIMER: Unsupported PKGBUILDs are user produced content, by downloading them you agree to do so at your own risk.")."</span>";
echo " </div>";
echo "</div>";
html_footer(AUR_VERSION);
diff --git a/web/html/packages.php b/web/html/packages.php
index 2ae3bf00..95b59798 100644
--- a/web/html/packages.php
+++ b/web/html/packages.php
@@ -491,55 +491,6 @@ if (isset($_REQUEST["do_Flag"])) {
# FIXME: If someone hits the detail page's vote button, this link dies
pkgsearch_results_link();
-
-} elseif (isset($_REQUEST["do_FlagSafe"])) {
- if (!$atype) {
- print __("You must be logged in before you can flag packages.");
- print "<br />\n";
- } else {
- if (!empty($ids) && $atype == "Trusted User") {
- $dbh = db_connect();
- # There currently shouldn't be multiple requests here, but the format in which
- # it's sent requires this
- while (list($pid, $v) = each($ids)) {
- $q = "UPDATE Packages SET Safe = 1, VerifiedBy = ".uid_from_sid($_COOKIE["AURSID"])." WHERE ID = ".$pid;
- db_query($q, $dbh);
- print '<p>';
- print __("The selected packages have been flagged safe.");
- print '<br /></p>';
- pkgdetails_link($pid);
- }
- } else {
- print '<p>';
- print __("Couldn't flag package safe.");
- print '<br /></p>';
- }
- }
-
-} elseif (isset($_REQUEST["do_UnFlagSafe"])) {
- if (!$atype) {
- print __("You must be logged in before you can unflag packages.");
- print "<br />\n";
- } else {
- if (!empty($ids) && $atype == "Trusted User") {
- $dbh = db_connect();
- # There currently shouldn't be multiple requests here, but the format in which
- # it's sent requires this
- while (list($pid, $v) = each($ids)) {
- $q = "UPDATE Packages SET Safe = 0 WHERE ID = ".$pid;
- db_query($q, $dbh);
- print '<p>';
- print __("The selected packages have been unflagged safe.");
- print '<br /></p>';
- pkgdetails_link($pid);
- }
- } else {
- print '<p>';
- print __("Couldn't unflag package safe.");
- print '<br /></p>';
- }
- }
-
} elseif (isset($_REQUEST["do_Notify"])) {
# I realize that the implementation here seems a bit convoluted, but we want to
# ensure that everything happens as it should, even if someone called this page
diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php
index 6e754bf6..9bed3f59 100644
--- a/web/html/pkgsubmit.php
+++ b/web/html/pkgsubmit.php
@@ -412,11 +412,6 @@ if ($_COOKIE["AURSID"]) {
$q.="Description='".mysql_real_escape_string($new_pkgbuild['pkgdesc'])."', ";
$q.="URL='".mysql_real_escape_string($new_pkgbuild['url'])."', ";
$q.="LocationID=2, ";
- if (account_from_sid($_COOKIE["AURSID"]) == "Trusted User" || account_from_sid($_COOKIE["AURSID"]) == "Developer") {
- $q.="Safe=1, VerifiedBy=".uid_from_sid($_COOKIE["AURSID"]).", ";
- } else {
- $q.="Safe=0, ";
- }
$fspath=INCOMING_DIR.$pkg_name."/".$_FILES["pfile"]["name"];
$q.="FSPath='".mysql_real_escape_string($fspath)."', ";
$urlpath=URL_DIR.$pkg_name."/".$_FILES["pfile"]["name"];
@@ -481,9 +476,6 @@ if ($_COOKIE["AURSID"]) {
#
$q = "INSERT INTO Packages ";
$q.= " (Name, License, Version, CategoryID, Description, URL, LocationID, ";
- if (account_from_sid($_COOKIE["AURSID"]) == "Trusted User" || account_from_sid($_COOKIE["AURSID"]) == "Developer") {
- $q.= "Safe, VerifiedBy,";
- }
$q.= " SubmittedTS, SubmitterUID, MaintainerUID, FSPath, URLPath) ";
$q.= "VALUES ('";
$q.= mysql_real_escape_string($new_pkgbuild['pkgname'])."', '";
diff --git a/web/lib/pkgfuncs.inc b/web/lib/pkgfuncs.inc
index 1d006936..a89cfa8b 100644
--- a/web/lib/pkgfuncs.inc
+++ b/web/lib/pkgfuncs.inc
@@ -355,15 +355,6 @@ function package_details($id=0, $SID="") {
echo "<a href='http://cvs.archlinux.org/cgi-bin/viewcvs.cgi/" . $row["Category"] . "/" . $row["Name"] . "/?cvsroot=AUR&only_with_tag=CURRENT'>CVS</td>";
}
echo "</tr>\n";
- if ($row["LocationID"] == 2) {
- echo " <tr><td colspan='3'>";
- if ($row["Safe"]) {
- echo "<span class='f7'>".__("The above files have been verified (by %h%s%h) and are safe to use.", array("<a href='/account.php?Action=AccountInfo&ID=".$row["VerifiedBy"]."'>", username_from_id($row["VerifiedBy"]), "</a>"))."</span></td>";
- } else {
- echo "<span class='f6'>".__("Be careful! The above files may contain malicious code that can damage your system.")."</span></td>";
- }
- echo " </tr>\n";
- }
if ($row["OutOfDate"] == 1) {
echo "\n<tr><td colspan='2'>";
echo "<span class='f6'>".__("This package has been flagged out of date.")."</span></td></tr>";
@@ -487,17 +478,6 @@ function package_details($id=0, $SID="") {
echo "<input type='submit' class='button' name='do_UnNotify'";
echo " value='".__("UnNotify")."' title='".__("No New Comment Notification")."'>";
}
- # Flag Safe Button
- #
- if ($row["LocationID"] == 2 && (account_from_sid($SID) == "Trusted User" || account_from_sid($SID) == "Developer")) {
- if ($row["Safe"] == 0) {
- echo "<input type='submit' class='button' name='do_FlagSafe'";
- echo " value='".__("Flag Safe")."' title='".__("Flag Package Safe To Use")."'>";
- } else {
- echo "<input type='submit' class='button' name='do_UnFlagSafe'";
- echo " value='".__("Unflag Safe")."' title='".__("Unflag Package Safe To Use")."'>";
- }
- }
if ($row["OutOfDate"] == 0) {
echo "<input type='submit' class='button' name='do_Flag'";
@@ -743,37 +723,6 @@ function pkg_search_page($SID="") {
print " </select>\n";
print "</td>\n";
- /* Status Safe-Unsafe */
-
- # Added the code below to handle the safe package flag.
- # So we can search for then for 'all' packages, 'safe'
- # packages and 'unsafe' packages.
-
- print "<td align='right'>\n";
- print " <span class='f5'><span class='blue'>".__("Status");
- print "</span></span><br />\n";
-
- print " <select name='PaS'>\n";
-
- # Flagged Safe
- print " <option value=all";
- $_REQUEST["PaS"] == "all" ? print " selected> " : print "> ";
- print __("All")."</option>\n";
-
- # Flagged Safe
- print " <option value=fs";
- $_REQUEST["PaS"] == "fs" ? print " selected> " : print "> ";
- print __("Safe")."</option>\n";
- # Unflagged Safe
- print " <option value=us";
- $_REQUEST["PaS"] == "us" ? print " selected> " : print "> ";
- print __("Unsafe")."</option>\n";
-
- print " </select>\n";
- print "</td>\n";
-
- /* End of Package Status */
-
/* Sort by */
print "<td align='right'>\n";
@@ -956,29 +905,6 @@ function pkg_search_page($SID="") {
$q.= "MaintainerUID = 0) ";
}
}
-
- # Added the code below to handle the safe package flag.
- # So we can search for then for 'all' packages, 'safe'
- # packages and 'unsafe' packages.
- if ($_REQUEST["PaS"] <> "all") {
- # Flagged Safe
- if ($_REQUEST["PaS"] == "fs")
- if (!$has_where) {
- $q.= "WHERE Safe = 1 ";
- $has_where = 1;
- } else {
- $q.= "AND Safe = 1 ";
- }
-
- # Unflagged Safe
- if ($_REQUEST["PaS"] == "us")
- if (!$has_where) {
- $q.= "WHERE Safe = 0 AND LocationID != 3 ";
- $has_where = 1;
- } else {
- $q.= "AND Safe = 0 AND LocationID != 3 ";
- }
- }
$order = $_REQUEST["SO"] == 'd' ? 'DESC' : 'ASC';
@@ -1158,13 +1084,7 @@ function pkg_search_page($SID="") {
}
reset($pkgsearch_vars);
$url.= "'>";
-
- if ($row["Safe"] == 1 || $locs[$row["LocationID"]] == "community") {
- $url.="<span class='green'>";
- }
- else {
- $url.="<span class='black'>";
- }
+ $url.="<span class='black'>";
$url.=$row["Name"];
$url.= " ".$row["Version"]."</span></a>";
print $url."</span></td>\n";
@@ -1243,7 +1163,6 @@ function pkg_search_page($SID="") {
if ($SID) {
print ' <span class="outofdate">'.__("Out of Date").' </span>'."&nbsp;&nbsp;&nbsp;&nbsp;";
}
- print ' <span class="green">'.__("Safe")."</span>\n";
print " </span></td>\n";
print " </tr>";