summaryrefslogtreecommitdiffstats
path: root/schema/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'schema/Makefile')
-rw-r--r--schema/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/schema/Makefile b/schema/Makefile
new file mode 100644
index 00000000..e0448add
--- /dev/null
+++ b/schema/Makefile
@@ -0,0 +1,11 @@
+aur-schema-sqlite.sql: aur-schema.sql
+ sed \
+ -e 's/ ENGINE = InnoDB//' \
+ -e 's/ [A-Z]* UNSIGNED NOT NULL AUTO_INCREMENT/ INTEGER NOT NULL/' \
+ -e 's/([0-9, ]*) UNSIGNED / UNSIGNED /' \
+ $< >$@
+
+clean:
+ rm -rf aur-schema-sqlite.sql
+
+.PHONY: clean