summaryrefslogtreecommitdiffstats
path: root/test/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile')
-rw-r--r--test/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/test/Makefile b/test/Makefile
index d6f0f740..4ce9b9be 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -1,6 +1,10 @@
+FOREIGN_TARGETS = ../schema/aur-schema-sqlite.sql
T = $(sort $(wildcard t[0-9][0-9][0-9][0-9]-*.sh))
-check: $(T)
+check: $(FOREIGN_TARGETS) $(T)
+
+$(FOREIGN_TARGETS):
+ $(MAKE) -C $(dir $@) $(notdir $@)
clean:
$(RM) -r test-results/
@@ -8,4 +12,4 @@ clean:
$(T):
@echo "*** $@ ***"; $(SHELL) $@
-.PHONY: check clean $(T)
+.PHONY: check $(FOREIGN_TARGETS) clean $(T)