summaryrefslogtreecommitdiffstats
path: root/contrib/PKGBUILD
diff options
context:
space:
mode:
authorJouke Witteveen <j.witteveen@gmail.com>2012-12-28 02:38:58 +0100
committerJouke Witteveen <j.witteveen@gmail.com>2012-12-28 02:38:58 +0100
commit4e457e0efd0e5fd5df24c7e9ed63b02d0196ea8d (patch)
tree09580c92ca78e8b9b54d7ed8d6b79d7fcd6fd9ff /contrib/PKGBUILD
parent6737a37e5666837a8f51a2f74bdebdd756151394 (diff)
downloadnetctl-4e457e0efd0e5fd5df24c7e9ed63b02d0196ea8d.tar.gz
netctl-4e457e0efd0e5fd5df24c7e9ed63b02d0196ea8d.tar.xz
Forking netcfg to netctl (1/2)
This commit contains the moving of files.
Diffstat (limited to 'contrib/PKGBUILD')
-rw-r--r--contrib/PKGBUILD31
1 files changed, 13 insertions, 18 deletions
diff --git a/contrib/PKGBUILD b/contrib/PKGBUILD
index 9ccc600..e743bfe 100644
--- a/contrib/PKGBUILD
+++ b/contrib/PKGBUILD
@@ -1,37 +1,32 @@
# Maintainer: Jouke Witteveen <j.witteveen@gmail.com>
-pkgname=netcfg
+pkgname=netctl
pkgver=%pkgver%
pkgrel=1
pkgdesc="Network configuration and profile scripts"
-url="http://archlinux.org/netcfg/"
-license=("BSD")
-backup=(etc/iftab etc/conf.d/netcfg)
-groups=(base)
-depends=("coreutils" "dhcpcd" "iproute2")
+url="http://archlinux.org/netctl/"
+license=("GPL")
+depends=("coreutils" "iproute2" "openresolv")
#makedepends=('asciidoc') # The source tarball includes pre-built documentation.
-optdepends=('dialog: for the menu based profile and wifi selectors'
+optdepends=('dialog: for the menu based wifi assistant'
+ 'dhclient: for DHCP support (or dhcpcd)'
+ 'dhcpcd: for DHCP support (or dhclient)'
'wpa_supplicant: for wireless networking support'
- 'ifplugd: for automatic wired connections through net-auto-wired'
- 'wpa_actiond: for automatic wireless connections through net-auto-wireless'
- 'wireless_tools: for interface renaming through net-rename'
+ 'ifplugd: for automatic wired connections through netctl-ifplugd'
+ 'wpa_actiond: for automatic wireless connections through netctl-auto'
'ifenslave: for bond connections'
'bridge-utils: for bridge connections'
)
-source=(ftp://ftp.archlinux.org/other/netcfg/netcfg-${pkgver}.tar.xz)
+conflicts=("netcfg")
+source=(ftp://ftp.archlinux.org/other/netctl/netctl-${pkgver}.tar.xz)
arch=(any)
md5sums=('%md5sum%')
package() {
- cd "$srcdir/netcfg-${pkgver}"
+ cd "$srcdir/netctl-${pkgver}"
make DESTDIR="$pkgdir" install
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/netcfg/LICENSE"
# Shell Completion
- install -D -m644 contrib/bash-completion "$pkgdir/usr/share/bash-completion/completions/netcfg"
- install -D -m644 contrib/zsh-completion "$pkgdir/usr/share/zsh/site-functions/_netcfg"
-
- # Compatibility
- ln -s netcfg.service "$pkgdir/usr/lib/systemd/system/net-profiles.service"
+ install -D -m644 contrib/bash-completion "$pkgdir/usr/share/bash-completion/completions/netctl"
}