summaryrefslogtreecommitdiffstats
path: root/contrib/PKGBUILD.in
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/PKGBUILD.in')
-rw-r--r--contrib/PKGBUILD.in36
1 files changed, 36 insertions, 0 deletions
diff --git a/contrib/PKGBUILD.in b/contrib/PKGBUILD.in
new file mode 100644
index 0000000..3c7b9b0
--- /dev/null
+++ b/contrib/PKGBUILD.in
@@ -0,0 +1,36 @@
+# Maintainer: Jouke Witteveen <j.witteveen@gmail.com>
+
+pkgname=netctl
+pkgver=@pkgver@
+pkgrel=1
+pkgdesc='Profile based systemd network management'
+url='http://projects.archlinux.org/netctl.git/'
+license=('GPL')
+groups=('base')
+depends=('coreutils' 'iproute2' 'openresolv')
+# The source tarball includes pre-built (using asciidoc) documentation.
+makedepends=('pkg-config')
+optdepends=('dialog: for the menu based wifi assistant'
+ 'dhclient: for DHCP support (or dhcpcd)'
+ 'dhcpcd: for DHCP support (or dhclient)'
+ 'wpa_supplicant: for wireless networking support'
+ 'ifplugd: for automatic wired connections through netctl-ifplugd'
+ 'wpa_actiond: for automatic wireless connections through netctl-auto'
+ 'ifenslave: for bond connections'
+ 'bridge-utils: for bridge connections'
+ 'ppp: for pppoe connections'
+ )
+source=(ftp://ftp.archlinux.org/other/packages/netctl/netctl-${pkgver}.tar.xz{,.sig})
+arch=('any')
+md5sums=('@md5sum@'
+ '@md5sum.sig@')
+
+package() {
+ cd "$srcdir/netctl-${pkgver}"
+ make DESTDIR="$pkgdir" install
+
+ # Shell Completion
+ install -D -m644 contrib/bash-completion "$pkgdir/usr/share/bash-completion/completions/netctl"
+ install -D -m644 contrib/zsh-completion "$pkgdir/usr/share/zsh/site-functions/_netctl"
+}
+