summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2012-04-25 03:44:29 +0200
committerDan McGee <dan@archlinux.org>2012-04-25 03:44:29 +0200
commit1583a2079c8e84c9cd960a596dae2e36c9077bbb (patch)
tree0f8e351dc930d5908d5ae27bd1b0d781bcbe8636 /Makefile.am
parent242411a1b4197910ac75b50033eb530004cc0e5c (diff)
downloadpacman-1583a2079c8e84c9cd960a596dae2e36c9077bbb.tar.gz
pacman-1583a2079c8e84c9cd960a596dae2e36c9077bbb.tar.xz
Split check steps in Makefile into multiple targets
This allows a `make -j4 check` invocation to actually run in parallel, even though 95% of our test suite time is currently dominated by pactest. It also allows running something like `make test-vercmp`. Also, add some targets to the .PHONY list that belong in it. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e08b809b..7d6f3065 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,14 +23,22 @@ dist_pkgdata_DATA = \
proto/ChangeLog.proto
# run the pactest test suite and vercmp tests
-check-local: test/pacman test/scripts test/util src/pacman src/util
+check-local: test-pacman test-pacsort test-vercmp test-parseopts
+
+test-pacman: test/pacman src/pacman
LC_ALL=C $(PYTHON) $(top_srcdir)/test/pacman/pactest.py --debug=1 \
--test $(top_srcdir)/test/pacman/tests/*.py \
-p $(top_builddir)/src/pacman/pacman
- $(SH) $(top_srcdir)/test/util/pacsorttest.sh \
+
+test-pacsort: test/util src/util
+ $(BASH_SHELL) $(top_srcdir)/test/util/pacsorttest.sh \
$(top_builddir)/src/util/pacsort
- $(SH) $(top_srcdir)/test/util/vercmptest.sh \
+
+test-vercmp: test/util src/util
+ $(BASH_SHELL) $(top_srcdir)/test/util/vercmptest.sh \
$(top_builddir)/src/util/vercmp
+
+test-parseopts: test/scripts scripts
$(BASH_SHELL) $(top_srcdir)/test/scripts/parseopts_test.sh \
$(top_srcdir)/scripts/library/parseopts.sh
@@ -45,4 +53,6 @@ update-po:
$(MAKE) -C scripts/po update-po
$(MAKE) -C src/pacman/po update-po
+.PHONY: test-pacman test-pacsort test-vercmp test-parseopts update-po
+
# vim:set ts=2 sw=2 noet: