summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew Gregory <andrew.gregory.8@gmail.com>2013-05-10 20:19:05 +0200
committerAllan McRae <allan@archlinux.org>2013-05-29 06:08:02 +0200
commit296e630edd129989856b1ebfaa7e8497a90bc937 (patch)
treecb6890275ec5a446d2e649c450f458e980072bf0 /Makefile.am
parent84ac55b0529b6489da38ebfc56a988228aa4859a (diff)
downloadpacman-296e630edd129989856b1ebfaa7e8497a90bc937.tar.gz
pacman-296e630edd129989856b1ebfaa7e8497a90bc937.tar.xz
pmtest: set LC_ALL=C in subprocess.call
LC_ALL=C is required to force pacman's output to English for tests that rely on that output, but setting it in Makefile.am results in those tests breaking under different locales when pactest.py is run directly. This will also ease an eventual transition to python3 which LC_ALL=C causes to default to ascii encoded strings, creating problems for tests with unicode strings. Signed-off-by: Andrew Gregory <andrew.gregory.8@gmail.com> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7b53fd0e..28f7f8f9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,7 +27,7 @@ dist_pkgdata_DATA = \
check-local: test-pacman test-pacsort test-vercmp test-parseopts
test-pacman: test/pacman src/pacman
- LC_ALL=C $(PYTHON) $(top_srcdir)/test/pacman/pactest.py --debug=1 \
+ $(PYTHON) $(top_srcdir)/test/pacman/pactest.py --debug=1 \
--test $(top_srcdir)/test/pacman/tests/*.py \
--scriptlet-shell $(SCRIPTLET_SHELL) \
--ldconfig $(LDCONFIG) \