summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew Gregory <andrew.gregory.8@gmail.com>2013-09-20 04:00:11 +0200
committerAllan McRae <allan@archlinux.org>2013-10-14 04:59:48 +0200
commit3a6bb2735b7715a8275826826ac3c525f03b121c (patch)
treefbf84ac3a076f4be7eb3ce1d280cb0bf7195860a /Makefile.am
parentd43f54e5c494a3796cf7fadece7ca4ce73ca807d (diff)
downloadpacman-3a6bb2735b7715a8275826826ac3c525f03b121c.tar.gz
pacman-3a6bb2735b7715a8275826826ac3c525f03b121c.tar.xz
Add make target for TESTS
This causes make to update TESTS when tests are added (or updated). For simplicity, this changes TESTS from a single multi-line list to individually appending each test file. Signed-off-by: Andrew Gregory <andrew.gregory.8@gmail.com> [Allan: use C locale for sorting] Signed-off-by: Allan McRae <allan@archlinux.org> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f81fd79e..0729be3d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,6 +23,9 @@ dist_pkgdata_DATA = \
proto/proto.install \
proto/ChangeLog.proto
+$(top_srcdir)/test/pacman/tests/TESTS: $(wildcard test/pacman/tests/*.py*)
+ @printf "TESTS += %s\n" $^ | sed -e "s/\.py\.in/.py/" | LC_ALL=C sort -u > "$@"
+
TESTS = test/scripts/parseopts_test.sh \
test/scripts/human_to_size_test.sh \
test/util/pacsorttest.sh \