summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew Gregory <andrew.gregory.8@gmail.com>2014-10-06 09:01:40 +0200
committerAllan McRae <allan@archlinux.org>2014-10-13 04:54:29 +0200
commit42c859e4cc38f91a1236cd93eae9e9f9a1bc1e62 (patch)
tree23ddd2d78b3fbe4ce2cfed46e7c47f6c9acb91ec /Makefile.am
parent01beca5df717252c7c9aa59bc705dc10a25ebdc8 (diff)
downloadpacman-42c859e4cc38f91a1236cd93eae9e9f9a1bc1e62.tar.gz
pacman-42c859e4cc38f91a1236cd93eae9e9f9a1bc1e62.tar.xz
pmtest: allow tests to specify test binary
Adds a cmd property to tests (defaults to pacman) which is resolved using directories specified with --bindir (defaults to PATH). The ability to manually specify a particular binary is preserved in order to allow running individual tests with differently named binaries such as lt-pacman. Signed-off-by: Andrew Gregory <andrew.gregory.8@gmail.com> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4c6f6565..44a23414 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,7 +45,8 @@ PY_LOG_COMPILER = $(PYTHON) $(top_srcdir)/test/pacman/pactest.py
AM_PY_LOG_FLAGS = \
--scriptlet-shell $(SCRIPTLET_SHELL) \
--ldconfig $(LDCONFIG) \
- -p $(top_builddir)/src/pacman/pacman
+ --bindir $(top_builddir)/src/pacman \
+ --bindir $(top_builddir)/scripts
# create the pacman DB and cache directories upon install
install-data-local: