summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2012-09-20 15:09:29 +0200
committerAllan McRae <allan@archlinux.org>2013-01-17 13:32:54 +0100
commit4a8c2852a887d2b1aaa43be3071ab586eb24b9e3 (patch)
tree13bd705ab4b7c139d1cc378f7c7c5fe715483402 /Makefile.am
parent993700bc6b12cd291544d2a22845f480e8a7925e (diff)
downloadpacman-4a8c2852a887d2b1aaa43be3071ab586eb24b9e3.tar.gz
pacman-4a8c2852a887d2b1aaa43be3071ab586eb24b9e3.tar.xz
pmtest: resolve path to scriptlet shell
In order to support a variety of values for the --with-scriptlet-shell configure flag, pmtest has to be aware of what kind of path was passed, be it an absolute path or a fragment for a path lookup. For absolute paths, leave the path alone. For fragments, search the PATH environment var for the resolved path to the binary. In both cases, join the resultant path to the root directory defined for the test, not a pre-determined bin directory. Fixes FS#31552. With-contribution-by: Dave Reisner <dreisner@archlinux.org> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b05feb68..cd69b6e7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,6 +28,7 @@ check-local: test-pacman test-pacsort test-vercmp test-parseopts
test-pacman: test/pacman src/pacman
LC_ALL=C $(PYTHON) $(top_srcdir)/test/pacman/pactest.py --debug=1 \
--test $(top_srcdir)/test/pacman/tests/*.py \
+ --scriptlet-shell $(SCRIPTLET_SHELL) \
-p $(top_builddir)/src/pacman/pacman
test-pacsort: test/util src/util