summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2016-01-26 12:02:07 +0100
committerAllan McRae <allan@archlinux.org>2016-01-29 00:50:11 +0100
commit6ea97963b3a67cfe346f40d2147fca918a118991 (patch)
treef8a7a5a8fe1021e0cacaf779a305157404414a2f /Makefile.am
parent5343ec76616aec3353f9106b7873ecdae2a2fe5a (diff)
downloadpacman-6ea97963b3a67cfe346f40d2147fca918a118991.tar.gz
pacman-6ea97963b3a67cfe346f40d2147fca918a118991.tar.xz
Create makepkg-template and system hook directories upon install
Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 3f10d156..a676878e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -51,9 +51,10 @@ AM_PY_LOG_FLAGS = \
--bindir $(top_builddir)/src/pacman \
--bindir $(top_builddir)/scripts
-# create the pacman DB and cache directories upon install
+# create the pacman DB, cache, makepkg-template and system hook directories upon install
install-data-local:
- for dir in "$(DESTDIR)$(localstatedir)/lib/pacman" "$(DESTDIR)$(localstatedir)/cache/pacman/pkg"; do \
+ for dir in "$(DESTDIR)$(localstatedir)/lib/pacman" "$(DESTDIR)$(localstatedir)/cache/pacman/pkg" \
+ "$(DESTDIR)$(datarootdir)/makepkg-template" "$(DESTDIR)$(datarootdir)/libalpm/hooks"; do \
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
done