summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2013-01-20 07:49:52 +0100
committerAllan McRae <allan@archlinux.org>2013-01-28 14:38:34 +0100
commit801f7d1033f74644c6d427cff9618270b2878582 (patch)
treeac2225cf4f0c6d68b0006e04f3088e72a537ceab /Makefile.am
parentad280e1b56b6c6632b2fae5288f6441c343d0185 (diff)
downloadpacman-801f7d1033f74644c6d427cff9618270b2878582.tar.gz
pacman-801f7d1033f74644c6d427cff9618270b2878582.tar.xz
pactest: handle non-default scriptlet shells
pacman can be configured to use a different shell than /bin/sh for scriplets. Pass the cnfigured value to the pactest suite and make the necessary "copy" of the shell in the test root. Also update all copyright years in the pactest suite. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b05feb68..cd69b6e7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,6 +28,7 @@ check-local: test-pacman test-pacsort test-vercmp test-parseopts
test-pacman: test/pacman src/pacman
LC_ALL=C $(PYTHON) $(top_srcdir)/test/pacman/pactest.py --debug=1 \
--test $(top_srcdir)/test/pacman/tests/*.py \
+ --scriptlet-shell $(SCRIPTLET_SHELL) \
-p $(top_builddir)/src/pacman/pacman
test-pacsort: test/util src/util