summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2013-01-20 12:56:57 +0100
committerAllan McRae <allan@archlinux.org>2013-01-28 14:38:46 +0100
commit89ecf8cabebfd13e50473fba7fb98f65a52b02d8 (patch)
treebb640857b2eb0d89ac3af16fcd4c02868e2acf22 /Makefile.am
parente3d8197d67336b6e59ee184762271cf64431aca6 (diff)
downloadpacman-89ecf8cabebfd13e50473fba7fb98f65a52b02d8.tar.gz
pacman-89ecf8cabebfd13e50473fba7fb98f65a52b02d8.tar.xz
Make path to ldconfig configurable
The FHS (2.3) says having ldconfig in /sbin is optional and it is usually located in /usr/sbin. So /sbin/ldconfig should not be hard coded in pacman. Instead, provide a configure option --with-ldconfig that defaults to the current path. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cd69b6e7..d4cc9fa4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,6 +29,7 @@ test-pacman: test/pacman src/pacman
LC_ALL=C $(PYTHON) $(top_srcdir)/test/pacman/pactest.py --debug=1 \
--test $(top_srcdir)/test/pacman/tests/*.py \
--scriptlet-shell $(SCRIPTLET_SHELL) \
+ --ldconfig $(LDCONFIG) \
-p $(top_builddir)/src/pacman/pacman
test-pacsort: test/util src/util