summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAaron Griffin <aaron@archlinux.org>2006-10-15 21:38:02 +0200
committerAaron Griffin <aaron@archlinux.org>2006-10-15 21:38:02 +0200
commit94810222866b7cc36bf442993826f9b38dbe9c41 (patch)
tree325266e9e88208d481ce58b866e7002af4d279c0 /Makefile.am
parent3f27542156125118800235c5ac1bac125fd7752c (diff)
downloadpacman-94810222866b7cc36bf442993826f9b38dbe9c41.tar.gz
pacman-94810222866b7cc36bf442993826f9b38dbe9c41.tar.xz
Final frugalware changes commit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 44523442..ebec81b1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,13 @@
-SUBDIRS = lib/libftp lib/libalpm src/util src/pacman scripts doc
+SUBDIRS = lib/libftp lib/libalpm src/util src/pacman scripts doc etc
+if HAS_PERL
+SUBDIRS += bindings/perl
+endif
+if HAS_PYTHON
+SUBDIRS += bindings/python
+endif
+if HAS_JAVA
+SUBDIRS += bindings/java
+endif
EXTRA_DIST = \
ChangeLog \
@@ -6,3 +15,6 @@ EXTRA_DIST = \
README \
TODO \
TODO.autoconf
+
+check:
+ cd pactest; python pactest.py --test=tests/*.py -p ../src/pacman/pacman --debug=1