summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-10-30 06:20:18 +0100
committerDan McGee <dan@archlinux.org>2007-10-30 06:20:18 +0100
commitac79135b94b1cd2c3fc4818bdfbe8ec63a6166b6 (patch)
tree4aa7171cc22a17c5e6fc91412f17589da8fd8d52 /Makefile.am
parent6aeda5fbff1969befa322ef7b79664f13dea1d18 (diff)
downloadpacman-ac79135b94b1cd2c3fc4818bdfbe8ec63a6166b6.tar.gz
pacman-ac79135b94b1cd2c3fc4818bdfbe8ec63a6166b6.tar.xz
Pick best python program available for 'make check'
Use an autoconf macro to find us a python executable, preferring python2.5 if we can find it. From there, fall back to python2.4 and then python. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 87bbee6a..e07321b3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,7 @@ EXTRA_DIST = HACKING
# run the pactest test suite
check-local: src/pacman
- python $(top_srcdir)/pactest/pactest.py --debug=1 \
+ $(PYTHON) $(top_srcdir)/pactest/pactest.py --debug=1 \
--test $(top_srcdir)/pactest/tests/*.py \
-p $(top_builddir)/src/pacman/pacman
rm -rf $(top_builddir)/root