summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2012-04-26 04:27:19 +0200
committerDan McGee <dan@archlinux.org>2012-06-26 06:39:12 +0200
commitb58489d29a1898a4bff1b5da6ca4bfb14003dbfe (patch)
tree5c42f704cc671136ef43972cfdee1274e620e65f /Makefile.am
parente183522e3168c4a31103b3c7910fa8d29333fb5a (diff)
downloadpacman-b58489d29a1898a4bff1b5da6ca4bfb14003dbfe.tar.gz
pacman-b58489d29a1898a4bff1b5da6ca4bfb14003dbfe.tar.xz
scripts/library: add human_to_size
This is a bash wrapper around an awk function that parses human readable sizes and returns their representative values in bytes, as a string. A small test harness is added to validate the functionality. Signed-off-by: Dave Reisner <dreisner@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7d6f3065..0010a3eb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,6 +41,8 @@ test-vercmp: test/util src/util
test-parseopts: test/scripts scripts
$(BASH_SHELL) $(top_srcdir)/test/scripts/parseopts_test.sh \
$(top_srcdir)/scripts/library/parseopts.sh
+ $(BASH_SHELL) $(top_srcdir)/test/scripts/human_to_size_test.sh \
+ $(top_srcdir)/scripts/library/human_to_size.sh
# create the pacman DB and cache directories upon install
install-data-local: