summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2015-01-21 07:28:24 +0100
committerAllan McRae <allan@archlinux.org>2015-02-01 12:19:03 +0100
commitbbac318d7a12500b1c3d0a57d0620d27edcd0422 (patch)
tree1304bc5c92aee934791dbb5d3b3ba2ed44da8bed /Makefile.am
parent54c630f6ecd74a44cc84f6804e918bda61310eef (diff)
downloadpacman-bbac318d7a12500b1c3d0a57d0620d27edcd0422.tar.gz
pacman-bbac318d7a12500b1c3d0a57d0620d27edcd0422.tar.xz
Add make rule to update copyright years
Usage: make update-copyright OLD=2014 NEW=2015 Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d2a11ebd..34489df8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -62,6 +62,11 @@ update-po:
$(MAKE) -C scripts/po update-po
$(MAKE) -C src/pacman/po update-po
-.PHONY: update-po
+update-copyright:
+ for file in $(shell sh -c 'git grep -l "Copyright .* Pacman Development" | grep -v "\.po"'); do \
+ sed -i -e "/Copyright (/s/-$(OLD)/-$(NEW)/" -e "/Copyright (/s/ $(OLD)/ $(OLD)-$(NEW)/" "$$file"; \
+ done
+
+.PHONY: update-po update-copyright
# vim:set noet: