summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorFlorian Pritz <bluewind@xinu.at>2014-12-21 15:46:37 +0100
committerAllan McRae <allan@archlinux.org>2015-01-11 09:58:24 +0100
commitca5af32b9931172387cf3df47cece22bf1523186 (patch)
treed62425ceb16514caaa6c36d4f71dbc965b4f232f /Makefile.am
parentf617b6acd4e33586819ac5728825cbdcac12f042 (diff)
downloadpacman-ca5af32b9931172387cf3df47cece22bf1523186.tar.gz
pacman-ca5af32b9931172387cf3df47cece22bf1523186.tar.xz
Add testrunner for makepkg-template
Signed-off-by: Florian Pritz <bluewind@xinu.at>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 01ea4f13..d2a11ebd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,6 +28,7 @@ $(top_srcdir)/test/pacman/tests/TESTS: $(wildcard test/pacman/tests/*.py*)
TESTS = test/scripts/parseopts_test.sh \
test/scripts/human_to_size_test.sh \
+ test/scripts/makepkg-template_test.sh \
test/scripts/pacman-db-upgrade-v9.py \
test/util/pacsorttest.sh \
test/util/vercmptest.sh
@@ -37,6 +38,7 @@ TEST_SUITE_LOG = test/test-suite.log
TEST_EXTENSIONS = .py
AM_TESTS_ENVIRONMENT = \
PMTEST_UTIL_DIR=$(top_builddir)/src/util/; export PMTEST_UTIL_DIR; \
+ PMTEST_SCRIPT_DIR=$(top_builddir)/scripts/; export PMTEST_SCRIPT_DIR; \
PMTEST_SCRIPTLIB_DIR=$(top_srcdir)/scripts/library/; export PMTEST_SCRIPTLIB_DIR;
LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
$(top_srcdir)/build-aux/tap-driver.sh