summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Fleischer <archlinux@cryptocrack.de>2011-12-12 22:36:56 +0100
committerDan McGee <dan@archlinux.org>2011-12-23 21:49:40 +0100
commitcd75ae46ab10fe295c5a3d3054a3b17eff31122a (patch)
treea24b4ec8a20be4d1a396d8e0b35e2bab059641bf /Makefile.am
parentc34b69b5c7aa86fe76f90577195d13bbcf300658 (diff)
downloadpacman-cd75ae46ab10fe295c5a3d3054a3b17eff31122a.tar.gz
pacman-cd75ae46ab10fe295c5a3d3054a3b17eff31122a.tar.xz
Makefile.am: Extract "contrib/" into DIST_SUBDIRS
This implies following changes: * contrib scripts can be built and installed easily by running make(1) in "contrib/". This removes the need to pick all contrib scripts manually when packaging pacman-contrib. * contrib scripts will no longer be built when running make(1) in the top level source directory. This seems like the most natural approach. We install those separately and should act the same when building stuff. Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6b24a4aa..a024a2e6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,10 @@
-SUBDIRS = lib/libalpm src/util src/pacman scripts etc test/pacman test/util contrib
+SUBDIRS = lib/libalpm src/util src/pacman scripts etc test/pacman test/util
if WANT_DOC
SUBDIRS += doc
endif
+DIST_SUBDIRS = $(SUBDIRS) contrib
+
ACLOCAL_AMFLAGS = -I m4 --install
# Make sure we test and build manpages when doing distcheck