summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew Gregory <andrew.gregory.8@gmail.com>2013-09-18 20:27:00 +0200
committerAllan McRae <allan@archlinux.org>2013-09-19 02:42:15 +0200
commitd1ac6ffc1399df928d768068231576b2ac3f5abe (patch)
tree1509731cfcbe496a96296493dfdc766ee0f3c06f /Makefile.am
parent2379eb1fa629eebd9de8c1a542734243ff2ef471 (diff)
downloadpacman-d1ac6ffc1399df928d768068231576b2ac3f5abe.tar.gz
pacman-d1ac6ffc1399df928d768068231576b2ac3f5abe.tar.xz
Fix make distcheck
* set util binary paths relative to top_builddir * set pactest.py path relative to top_srcdir * include tap.py in check_SCRIPTS Signed-off-by: Andrew Gregory <andrew.gregory.8@gmail.com> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 77bc06da..f81fd79e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,13 +31,13 @@ include $(top_srcdir)/test/pacman/tests/TESTS
TEST_EXTENSIONS = .py
AM_TESTS_ENVIRONMENT = \
- PMTEST_UTIL_DIR=$(top_srcdir)/src/util/; export PMTEST_UTIL_DIR; \
+ PMTEST_UTIL_DIR=$(top_builddir)/src/util/; export PMTEST_UTIL_DIR; \
PMTEST_SCRIPTLIB_DIR=$(top_srcdir)/scripts/library/; export PMTEST_SCRIPTLIB_DIR;
TEST_LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
$(top_srcdir)/build-aux/tap-driver.sh
PY_LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
$(top_srcdir)/build-aux/tap-driver.sh
-PY_LOG_COMPILER = test/pacman/pactest.py
+PY_LOG_COMPILER = $(top_srcdir)/test/pacman/pactest.py
AM_PY_LOG_FLAGS = \
--scriptlet-shell $(SCRIPTLET_SHELL) \
--ldconfig $(LDCONFIG) \