summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2011-05-05 18:10:44 +0200
committerDan McGee <dan@archlinux.org>2011-05-05 18:12:26 +0200
commitd360153bc6d4368e18a6d2e169d7d667e1640992 (patch)
tree32d4e5144426d6bfe95386eb1e157538f3050712 /Makefile.am
parent47de7973fd501e5253386c50178ec47e9f4c4c8e (diff)
downloadpacman-d360153bc6d4368e18a6d2e169d7d667e1640992.tar.gz
pacman-d360153bc6d4368e18a6d2e169d7d667e1640992.tar.xz
pactest: run with root in /tmp and clean up automatically
This moves the generated root/ directory into /tmp, or at least a path returned by tempfile.mkdtemp(), by default. This can make test runs significantly faster if done when /tmp is a tmpfs. If you are debugging a failed test, use the new --keep-root option to not clean up and pactest will print the location of the generated root/ test directory. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 32a08f71..259a455b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,6 @@ check-local: test/pacman test/util src/pacman src/util
$(PYTHON) $(top_srcdir)/test/pacman/pactest.py --debug=1 \
--test $(top_srcdir)/test/pacman/tests/*.py \
-p $(top_builddir)/src/pacman/pacman
- rm -rf $(top_builddir)/root
$(SH) $(top_srcdir)/test/util/vercmptest.sh \
$(top_builddir)/src/util/vercmp