summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2011-08-08 22:24:04 +0200
committerDan McGee <dan@archlinux.org>2011-08-08 23:55:01 +0200
commitd9f9b87d3ff6621577aa15bf3304f73219f6d5f1 (patch)
tree2957a73800af6d9f4f56e28cdd7f28ab059c030e /Makefile.am
parent1d37c19e0492ddd426c7a05c815a45b997b55498 (diff)
downloadpacman-d9f9b87d3ff6621577aa15bf3304f73219f6d5f1.tar.gz
pacman-d9f9b87d3ff6621577aa15bf3304f73219f6d5f1.tar.xz
Add a test harness for new pacsort command
Note that this is meant to exercise pacsort more than the underlying version comparsion; that is better left to the standalone vercmptest.sh test script. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 286e6ae6..75760bb3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,6 +25,8 @@ check-local: test/pacman test/util src/pacman src/util
$(PYTHON) $(top_srcdir)/test/pacman/pactest.py --debug=1 \
--test $(top_srcdir)/test/pacman/tests/*.py \
-p $(top_builddir)/src/pacman/pacman
+ $(SH) $(top_srcdir)/test/util/pacsorttest.sh \
+ $(top_builddir)/src/util/pacsort
$(SH) $(top_srcdir)/test/util/vercmptest.sh \
$(top_builddir)/src/util/vercmp