summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew Gregory <andrew.gregory.8@gmail.com>2013-11-05 14:50:44 +0100
committerAllan McRae <allan@archlinux.org>2013-11-15 02:02:27 +0100
commitea6aeef8bae01d934cb4aab6d915e0e3e8276df1 (patch)
tree8bde92c911271127efc2fdf20f986e94d3814f96 /Makefile.am
parent0da98ec6bac17b4f56b67a6f5b2fa24896671a9f (diff)
downloadpacman-ea6aeef8bae01d934cb4aab6d915e0e3e8276df1.tar.gz
pacman-ea6aeef8bae01d934cb4aab6d915e0e3e8276df1.tar.xz
Makefile.am: fix typo in LOG_DRIVER variable
Self-executing tests were not being run through the tap log driver. This caused `make check` to ignore discrepancies between the expected number of tests and the actual number of tests. Also, fix some uncommented output from test scripts that could confuse TAP parsers. Signed-off-by: Andrew Gregory <andrew.gregory.8@gmail.com> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0ba39ca2..4d5adae3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,7 +36,7 @@ TEST_EXTENSIONS = .py
AM_TESTS_ENVIRONMENT = \
PMTEST_UTIL_DIR=$(top_builddir)/src/util/; export PMTEST_UTIL_DIR; \
PMTEST_SCRIPTLIB_DIR=$(top_srcdir)/scripts/library/; export PMTEST_SCRIPTLIB_DIR;
-TEST_LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
$(top_srcdir)/build-aux/tap-driver.sh
PY_LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
$(top_srcdir)/build-aux/tap-driver.sh