summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeremy Heiner <scalaprotractor@gmail.com>2013-12-20 17:59:46 +0100
committerAllan McRae <allan@archlinux.org>2013-12-21 01:20:04 +0100
commitf7f8964c2315c81939798e870f96083146bbb27c (patch)
treee45e5f894eb5034e735710b8a9b0e43abad84628 /Makefile.am
parent50e9543908817940792cd9a590c42aed5230c311 (diff)
downloadpacman-f7f8964c2315c81939798e870f96083146bbb27c.tar.gz
pacman-f7f8964c2315c81939798e870f96083146bbb27c.tar.xz
Use the 'configure'd PYTHON to run pactest.
Use the 'configure'd PYTHON to run pactest instead of the one hard-coded (with '#!') in pactest.py. Also remove useless '#!' from non-main .py files. Signed-off-by: Jeremy Heiner <ScalaProtractor at gmail.com> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4d5adae3..d22c52e6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,7 +40,7 @@ LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
$(top_srcdir)/build-aux/tap-driver.sh
PY_LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
$(top_srcdir)/build-aux/tap-driver.sh
-PY_LOG_COMPILER = $(top_srcdir)/test/pacman/pactest.py
+PY_LOG_COMPILER = $(PYTHON) $(top_srcdir)/test/pacman/pactest.py
AM_PY_LOG_FLAGS = \
--scriptlet-shell $(SCRIPTLET_SHELL) \
--ldconfig $(LDCONFIG) \