summaryrefslogtreecommitdiffstats
path: root/PKGBUILD-split.proto
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2009-01-16 13:16:18 +0100
committerAllan McRae <allan@archlinux.org>2009-01-16 13:16:18 +0100
commit219cb2eaacf1ff35bd04cd64d0f8b616a732e185 (patch)
tree3a1902175f0cc069d9a937aa8c03b1dedbcb33fa /PKGBUILD-split.proto
parent7a3a718c7af493049cf7f9b7c65032f59cc8a71d (diff)
downloadpacman-219cb2eaacf1ff35bd04cd64d0f8b616a732e185.tar.gz
pacman-219cb2eaacf1ff35bd04cd64d0f8b616a732e185.tar.xz
makepkg: Add PKGBUILD-split.proto
Prototype PKGBUILD for package splitting in makepkg Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'PKGBUILD-split.proto')
-rw-r--r--PKGBUILD-split.proto55
1 files changed, 55 insertions, 0 deletions
diff --git a/PKGBUILD-split.proto b/PKGBUILD-split.proto
new file mode 100644
index 00000000..35fb22b9
--- /dev/null
+++ b/PKGBUILD-split.proto
@@ -0,0 +1,55 @@
+# This is an example of a PKGBUILD for splitting packages. Use this as a
+# start to creating your own, and remove these comments. For more information,
+# see 'man PKGBUILD'. NOTE: Please fill out the license field for your package!
+# If it is unknown, then please put 'unknown'.
+
+# Contributor: Your Name <youremail@domain.com>
+pkgname=('pkg1' 'pkg2')
+pkgver=VERSION
+pkgrel=1
+pkgdesc=""
+arch=()
+url=""
+license=('GPL')
+groups=()
+depends=()
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=($pkgname-$pkgver.tar.gz)
+noextract=()
+md5sums=() #generate with 'makepkg -g'
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package_pkg1() {
+ # options and directives that can be overridden
+ pkgdesc=""
+ license=()
+ groups=()
+ depends=()
+ optdepends=()
+ provides=()
+ conflicts=()
+ replaces=()
+ backup=()
+ options=()
+ install=
+
+ make DESTDIR="$pkgdir/" install-pkg1
+}
+
+package_pkg2() {
+ # options and directives overrides
+ pkgdesc=""
+
+ make DESTDIR="$pkgdir/" install-pkg2
+}