summaryrefslogtreecommitdiffstats
path: root/PKGBUILD-split.proto
diff options
context:
space:
mode:
authorCedric Staniewski <cedric@gmx.ca>2009-10-08 16:10:05 +0200
committerDan McGee <dan@archlinux.org>2009-10-12 05:35:20 +0200
commit2cabe336eb33e443819a1d9d46b0c5bcceaa7e87 (patch)
tree710754a2eb38318e7e4be004ea53194d795c64a2 /PKGBUILD-split.proto
parente3ac8062626877b8cf87df5ce94f61394bf10c0f (diff)
downloadpacman-2cabe336eb33e443819a1d9d46b0c5bcceaa7e87.tar.gz
pacman-2cabe336eb33e443819a1d9d46b0c5bcceaa7e87.tar.xz
Introduce new PKGBUILD variable `changelog`
Currently, a changelog is added to a package if a specific file with a hardcoded name exists in the PKGBUILD's directory. This approach is not pretty and also inconsistent with the handling of install files, but it works. With the introduction of split PKGBUILDs, however, a drawback in this old behavior has arisen: you only have the possibility to include one specific changelog file in either every package defined in the PKGBUILD or in none. The use of an additional variable, `changelog`, works around this issue and makes it possible to include a changelog in only some of the packages, and besides, each package of the PKGBUILD can have its own changelog file. Signed-off-by: Cedric Staniewski <cedric@gmx.ca> Signed-off-by: Allan McRae <allan@archlinux.org> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'PKGBUILD-split.proto')
-rw-r--r--PKGBUILD-split.proto2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD-split.proto b/PKGBUILD-split.proto
index 08f98d62..11ceff2b 100644
--- a/PKGBUILD-split.proto
+++ b/PKGBUILD-split.proto
@@ -21,6 +21,7 @@ replaces=()
backup=()
options=()
install=
+changelog=
source=($pkgbase-$pkgver.tar.gz)
noextract=()
md5sums=() #generate with 'makepkg -g'
@@ -44,6 +45,7 @@ package_pkg1() {
backup=()
options=()
install=
+ changelog=
cd "$srcdir/$pkgbase-$pkgver"
make DESTDIR="$pkgdir/" install-pkg1