summaryrefslogtreecommitdiffstats
path: root/PKGBUILD.proto
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2008-01-06 17:23:49 +0100
committerDan McGee <dan@archlinux.org>2008-01-06 17:23:49 +0100
commitd53388fb90ee9594e07b8f00cc45436e6318c972 (patch)
tree0c1f025fd7adaec0f787adca3393ef3a9ba51451 /PKGBUILD.proto
parente0e33c329ff249d7862a0e7ec508794faa98efd8 (diff)
downloadpacman-d53388fb90ee9594e07b8f00cc45436e6318c972.tar.gz
pacman-d53388fb90ee9594e07b8f00cc45436e6318c972.tar.xz
install: install prototype PKGBUILD and install to datadir
Move the prototypes out of contrib/ and into the top level directory, and install them to what is usually /usr/share/pacman/ on a package install. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'PKGBUILD.proto')
-rw-r--r--PKGBUILD.proto35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD.proto b/PKGBUILD.proto
new file mode 100644
index 00000000..9e4b69a0
--- /dev/null
+++ b/PKGBUILD.proto
@@ -0,0 +1,35 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Contributor: Your Name <youremail@domain.com>
+pkgname=NAME
+pkgver=VERSION
+pkgrel=1
+pkgdesc=""
+arch=()
+url=""
+license=('GPL')
+groups=()
+depends=()
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=($pkgname-$pkgver.tar.gz)
+noextract=()
+md5sums=() #generate with 'makepkg -g'
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: