summaryrefslogtreecommitdiffstats
path: root/PKGBUILD.proto
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2010-05-19 12:33:35 +0200
committerAllan McRae <allan@archlinux.org>2010-05-19 12:33:35 +0200
commitf948cb25bb3bc4ebfdd9d759451586e1baeb7b86 (patch)
tree5d8f4d64584aece76926c6d499c49607db83643f /PKGBUILD.proto
parent9ab6bfad223ce65d3c37785d0aae8676bfc2702f (diff)
downloadpacman-f948cb25bb3bc4ebfdd9d759451586e1baeb7b86.tar.gz
pacman-f948cb25bb3bc4ebfdd9d759451586e1baeb7b86.tar.xz
Change directory in package function in PKGBUILD.proto
makepkg goes back to the $startdir between the build() and package() functions so we need to change directory at the start of the package function. TODO: fix makepkg to make this unnecessary Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'PKGBUILD.proto')
-rw-r--r--PKGBUILD.proto2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD.proto b/PKGBUILD.proto
index 01345742..b4d9c94b 100644
--- a/PKGBUILD.proto
+++ b/PKGBUILD.proto
@@ -34,6 +34,8 @@ build() {
}
package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
make DESTDIR="$pkgdir/" install
}