summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2012-04-17 21:58:51 +0200
committerDan McGee <dan@archlinux.org>2012-04-24 15:34:17 +0200
commit1eb6a9cbfef4f0ad5151b4850d81141b7a535be6 (patch)
treea5a02172d35247389ca6ceddb67d34c94205589d /configure.ac
parentd7b728591ad68712be2c0ade7c2dd8e45bc2dfed (diff)
downloadpacman-1eb6a9cbfef4f0ad5151b4850d81141b7a535be6.tar.gz
pacman-1eb6a9cbfef4f0ad5151b4850d81141b7a535be6.tar.xz
configure: avoid linking against libssl
We're not linking to libssl, only libcrypto. -Wl,--as-needed will get rid of this, but there's no sense in checking for and linking against a library we don't need. Signed-off-by: Dave Reisner <dreisner@archlinux.org> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index eccf425b..8898f146 100644
--- a/configure.ac
+++ b/configure.ac
@@ -164,7 +164,7 @@ PKG_CHECK_MODULES(LIBARCHIVE, [libarchive >= 2.8.0], ,
# Check for OpenSSL
have_openssl=no
if test "x$with_openssl" != "xno"; then
- PKG_CHECK_MODULES(LIBSSL, [libssl libcrypto],
+ PKG_CHECK_MODULES(LIBSSL, [libcrypto],
[AC_DEFINE(HAVE_LIBSSL, 1, [Define if libcrypto is available]) have_openssl=yes], have_openssl=no)
if test "x$have_openssl" = xno -a "x$with_openssl" = xyes; then
AC_MSG_ERROR([*** openssl support requested but libraries not found])