summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-12-22 06:47:18 +0100
committerDan McGee <dan@archlinux.org>2007-12-29 03:06:58 +0100
commit26c05b1c8c6fe639cd4eea5decac694c86cc7c00 (patch)
tree072c3b517bad8d76dc9f7a94e03260fa6d956a0a /configure.ac
parentfdab7207e2bc96ca0f22397a0073f5d1a9c2a2c7 (diff)
downloadpacman-26c05b1c8c6fe639cd4eea5decac694c86cc7c00.tar.gz
pacman-26c05b1c8c6fe639cd4eea5decac694c86cc7c00.tar.xz
Ensure that manpages are always distributed and installed
Commit 012f7939784358b02726c169543aa99436439335 was a bit misguided in its thinking, and resulted in a package built without asciidoc enabled not installing the manpages to the system on a 'make install' operation. Fix this behavior by making manpages required in a normal build, and in order to disable their existence, the '--disable-doc' option must be used. Hopefully this solves manpage issues for both developers and package builders while allowing as much flexibility as possible. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bed26cfd..64715959 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,6 +98,11 @@ AC_ARG_WITH(db-ext,
AC_HELP_STRING([--with-db-ext=ext], [set the file extension used by the database]),
[DBEXT=$withval], [DBEXT=.db.tar.gz])
+# Help line for documentation
+AC_ARG_ENABLE(doc,
+ AC_HELP_STRING([--disable-doc], [prevent make from looking at doc/ dir]),
+ [wantdoc=$enableval], [wantdoc=yes])
+
# Help line for doxygen
AC_ARG_ENABLE(doxygen,
AC_HELP_STRING([--enable-doxygen], [build your own API docs via Doxygen]),
@@ -218,6 +223,17 @@ AC_SUBST(CARCH)
AC_SUBST(CARCHFLAGS)
AC_SUBST(CHOST)
+# Check for documentation support and status
+AC_MSG_CHECKING([for building documentation])
+if test "x$wantdoc" = "xyes" ; then
+ AC_MSG_RESULT([yes])
+ wantdoc=yes
+else
+ AC_MSG_RESULT([no, disabled by configure])
+ wantdoc=no
+fi
+AM_CONDITIONAL(WANT_DOC, test "x$wantdoc" = "xyes")
+
# Check for doxygen support and status
AC_MSG_CHECKING([for doxygen])
if test "x$wantdoxygen" = "xyes" ; then
@@ -336,6 +352,7 @@ pacman_display_version:
database extension : ${DBEXT}
Compilation options:
+ Run make in doc/ dir : ${wantdoc}
Doxygen support : ${usedoxygen}
Asciidoc support : ${useasciidoc}
debug support : ${debug}