summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2008-12-07 18:58:24 +0100
committerDan McGee <dan@archlinux.org>2011-03-23 09:16:29 +0100
commit39c75c70001eac9362d70141372f3e26c254680b (patch)
tree32e21d71f7616685e7fb115a12dc3d2cf9004db6 /configure.ac
parent061948597dd0fc4fda4197b7bfca6f730c43b9c8 (diff)
downloadpacman-39c75c70001eac9362d70141372f3e26c254680b.tar.gz
pacman-39c75c70001eac9362d70141372f3e26c254680b.tar.xz
Integrate GPGME into libalpm
Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 45b0a4bb..defa3da1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -161,6 +161,10 @@ AS_IF([test "x$with_curl" != "xno"],
AC_MSG_RESULT(no))
AM_CONDITIONAL([HAVE_LIBCURL], [test "x$ac_cv_lib_curl_curl_easy_perform" = "xyes"])
+# Check for gpgme
+AC_CHECK_LIB([gpgme], [gpgme_check_version], ,
+ AC_MSG_ERROR([gpgme is needed to compile pacman!]))
+
# Checks for header files.
AC_CHECK_HEADERS([fcntl.h glob.h libintl.h locale.h mntent.h string.h \
sys/ioctl.h sys/mount.h sys/param.h sys/statvfs.h \