summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2011-02-09 04:19:00 +0100
committerDan McGee <dan@archlinux.org>2011-02-11 17:38:58 +0100
commit3afe3b6dfb928200166f348964de24e3f7188568 (patch)
treeef129c6235014841c8734218493bd20789537db7 /configure.ac
parent1358a4a80f4d8edbeedc0fdd1e026b491cbb8815 (diff)
downloadpacman-3afe3b6dfb928200166f348964de24e3f7188568.tar.gz
pacman-3afe3b6dfb928200166f348964de24e3f7188568.tar.xz
Check mountpoint read-only status when checking space
This is a bit of a stopgap solution for the problem, but an easier one than revamping the file conflict checking code to support the same stuff. Using some more gross autoconf magic, figure out which struct field we need to look at to determine read-only status and store that on our mountpoint struct. If we find out we needed this partition after calculating size requirements, then toss an error. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 47d60938..1039bba1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,6 +194,10 @@ AC_CHECK_FUNCS([geteuid getmntinfo realpath regcomp strcasecmp \
wcwidth uname])
# For the diskspace code
FS_STATS_TYPE
+AC_CHECK_MEMBERS([struct statvfs.f_flag],,,[[#include <sys/statvfs.h>]])
+AC_CHECK_MEMBERS([struct statfs.f_flags],,,[[#include <sys/param.h>
+ #include <sys/mount.h>]])
+
# Enable large file support if available
AC_SYS_LARGEFILE