summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-08-14 15:33:55 +0200
committerDan McGee <dan@archlinux.org>2007-08-14 15:33:55 +0200
commit49c29e16b31ce35e81be210bc74a3834530bb9e0 (patch)
tree6af42b0e318e257d55a41c125c479cf6609c5225 /configure.ac
parent47ee89ada9d13935510ef92541649901789c23c8 (diff)
downloadpacman-49c29e16b31ce35e81be210bc74a3834530bb9e0.tar.gz
pacman-49c29e16b31ce35e81be210bc74a3834530bb9e0.tar.xz
Code cleanup
Remove the commented desc_localized stuff, we can find it later in version control. Also remove some unnecessary includes of the stat header and use -fstack-protector-all which is a bit more broad. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 70021730..ff6a0082 100644
--- a/configure.ac
+++ b/configure.ac
@@ -201,7 +201,7 @@ AM_CONDITIONAL(HAS_DOXYGEN, test "x$usedoxygen" = "xyes")
AC_MSG_CHECKING(for debug mode request)
if test "x$debug" = "xyes" ; then
AC_DEFINE([PACMAN_DEBUG], , [Enable debug code])
- CFLAGS="$CFLAGS -g -Wall -Werror -fstack-protector -std=c99"
+ CFLAGS="$CFLAGS -g -Wall -Werror -fstack-protector-all -std=c99"
LDFLAGS="$LDFLAGS -lmcheck"
AC_MSG_RESULT(yes)
else