summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-02-24 21:25:45 +0100
committerDan McGee <dan@archlinux.org>2007-02-24 21:25:45 +0100
commit5579607899e98b3fb6d3d9388cd3b01ca63a2a00 (patch)
treea90a3ae8f9d0269b9d4c8f94857f7c4199d015fa /configure.ac
parent8626e5dd474b61827a6cb5b1f02f92f75c96a6ac (diff)
downloadpacman-5579607899e98b3fb6d3d9388cd3b01ca63a2a00.tar.gz
pacman-5579607899e98b3fb6d3d9388cd3b01ca63a2a00.tar.xz
* Updated Italian translation
Giovanni Scafora <linuxmania@gmail.com> * added '-fstack-protector' flag to debug compile, to catch any buffer overflows we may have in stack variables.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d0b9d35f..d0d6fd36 100644
--- a/configure.ac
+++ b/configure.ac
@@ -161,7 +161,7 @@ dnl Enable or disable debug code
AC_MSG_CHECKING(for debug mode request)
if test "x$debug" = "xyes" ; then
AC_DEFINE([PACMAN_DEBUG], , [Enable debug code])
- CFLAGS="$CFLAGS -g -Wall -Werror -std=c99"
+ CFLAGS="$CFLAGS -g -Wall -Werror -fstack-protector -std=c99"
LDFLAGS="$LDFLAGS -lmcheck"
AC_MSG_RESULT(yes)
else