summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCedric Staniewski <cedric@gmx.ca>2009-12-21 20:26:28 +0100
committerDan McGee <dan@archlinux.org>2010-03-15 00:34:16 +0100
commit5fe41df8a9eaac288433a54e216f96b1fe729c01 (patch)
tree489613b7b44d05b6a10190a134b19858192e2732 /configure.ac
parent22331fdadb1b055030a6f68e2bb9eed589187a10 (diff)
downloadpacman-5fe41df8a9eaac288433a54e216f96b1fe729c01.tar.gz
pacman-5fe41df8a9eaac288433a54e216f96b1fe729c01.tar.xz
makepkg: make strip options configurable
The newly added variables STRIP_BINARIES, STRIP_SHARED and STRIP_STATIC, that are set in makepkg.conf, specify the strip options used on binaries and shared and static libraries. In addition, files are now stripped more aggressively by default. Implements FS#13592 the way it was suggested by Allan in the comments. Signed-off-by: Cedric Staniewski <cedric@gmx.ca> Signed-off-by: Allan McRae <allan@archlinux.org> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 80e41a6e..faf774fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -186,6 +186,9 @@ GCC_GNU89_INLINE_CC
# Host-dependant definitions
SIZECMD="stat -L -c %s"
SEDINPLACE="sed -i"
+STRIP_BINARIES="--strip-all"
+STRIP_SHARED="--strip-unneeded"
+STRIP_STATIC="--strip-debug"
case "${host_os}" in
*bsd*)
SIZECMD="stat -L -f %z"
@@ -199,6 +202,9 @@ case "${host_os}" in
host_os_darwin=yes
SIZECMD="/usr/bin/stat -L -f %z"
SEDINPLACE="/usr/bin/sed -i ''"
+ STRIP_BINARIES=""
+ STRIP_SHARED="-S"
+ STRIP_STATIC="-S"
;;
esac
@@ -206,6 +212,9 @@ AM_CONDITIONAL([CYGWIN], test "x$host_os_cygwin" = "xyes")
AM_CONDITIONAL([DARWIN], test "x$host_os_darwin" = "xyes")
AC_SUBST(SIZECMD)
AC_SUBST(SEDINPLACE)
+AC_SUBST(STRIP_BINARIES)
+AC_SUBST(STRIP_SHARED)
+AC_SUBST(STRIP_STATIC)
# Check for architecture, used in default makepkg.conf
# (Note single space left after CARCHFLAGS)