summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Reisner <d@falconindy.com>2010-12-16 23:19:07 +0100
committerDave Reisner <d@falconindy.com>2011-03-09 21:22:32 +0100
commit67391c2c6cfa0044f554fb6a6b9717175d8d83a3 (patch)
tree767d2ce0a3ca98b923ac72c5e18a776d4e7ffa88 /configure.ac
parent36c570712a34cda92ce3c3362d07baff41ba0d04 (diff)
downloadpacman-67391c2c6cfa0044f554fb6a6b9717175d8d83a3.tar.gz
pacman-67391c2c6cfa0044f554fb6a6b9717175d8d83a3.tar.xz
Add configure.ac option for --with-curl
To avoid breaking compilation, fetch defaults to 'no', and curl defaults to 'check'. Signed-off-by: Dave Reisner <d@falconindy.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1039bba1..0ae9cba8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,7 +96,12 @@ AC_ARG_WITH(openssl,
# Help line for libfetch
AC_ARG_WITH(fetch,
AS_HELP_STRING([--with-fetch], [use libfetch as an internal downloader]),
- [], [with_fetch=check])
+ [], [with_fetch=no])
+
+# Help line for libcurl
+AC_ARG_WITH(curl,
+ AS_HELP_STRING([--with-curl], [use libcurl as an internal downloader]),
+ [], [with_curl=check])
# Help line for documentation
AC_ARG_ENABLE(doc,
@@ -149,6 +154,18 @@ AS_IF([test "x$with_openssl" != "xno"],
AC_MSG_RESULT(no))
AM_CONDITIONAL([HAVE_LIBSSL], [test "x$ac_cv_lib_ssl_MD5_Final" = "xyes"])
+# Enable or disable usage of libcurl
+AC_MSG_CHECKING(whether to link with libcurl)
+AS_IF([test "x$with_curl" != "xno"],
+ [AC_MSG_RESULT(yes)
+ AC_CHECK_LIB([curl], [curl_easy_perform], ,
+ [if test "x$with_curl" != "xcheck"; then
+ AC_MSG_FAILURE([--with-curl was given, but -lcurl was not found])
+ fi],
+ [-lcurl])],
+ AC_MSG_RESULT(no))
+AM_CONDITIONAL([HAVE_LIBCURL], [test "x$ac_cv_lib_curl_curl_easy_perform" = "xyes"])
+
# Enable or disable usage of libfetch
AC_MSG_CHECKING(whether to link with libfetch)
AS_IF([test "x$with_fetch" != "xno"],