summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew Fyfe <andrew@neptune-one.net>2007-06-01 00:44:00 +0200
committerDan McGee <dan@archlinux.org>2007-06-01 00:44:00 +0200
commit6d649473fa62726d783081025318f5add307b2d6 (patch)
tree96196fbe585c7367e53efc0fc47d8d4f0b165911 /configure.ac
parentaf888c534b7c106ba89069ef6b11ea63d9f24975 (diff)
downloadpacman-6d649473fa62726d783081025318f5add307b2d6.tar.gz
pacman-6d649473fa62726d783081025318f5add307b2d6.tar.xz
FS7319: Add option to disable the inclusion of abs script.
Signed-off-by: Andrew Fyfe <andrew@neptune-one.net> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7ab8e3a0..86df9978 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,6 +58,11 @@ AC_ARG_ENABLE(debug,
AC_HELP_STRING([--enable-debug], [Enable debugging support]),
[debug=$enableval], [debug=no])
+# Help line for abs
+AC_ARG_ENABLE(abs,
+ AC_HELP_STRING([--disable-abs], [Include Arch Linux Build System script]),
+ [includeabs=$enableval], [includeabs=yes])
+
# Checks for programs.
AC_PROG_AWK
AC_PROG_CC
@@ -193,6 +198,16 @@ else
AC_MSG_RESULT(no)
fi
+# Enable or disable inclusion of abs script
+AC_MSG_CHECKING(for inclusion of abs script)
+if test "x$includeabs" = "xyes" ; then
+ AC_DEFINE([INCLUDE_ABS], , [Include abs script])
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+fi
+AM_CONDITIONAL(INCLUDE_ABS, test "x$includeabs" = "xyes")
+
# Set root directory
AC_SUBST(ROOTDIR)
AC_DEFINE_UNQUOTED([ROOTDIR], "$ROOTDIR", [Location of pacman's default root di
@@ -257,4 +272,5 @@ $PACKAGE_STRING:
Compilation options:
Doxygen support : ${usedoxygen}
debug support : ${debug}
+ include abs : ${includeabs}
"