summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2010-10-14 00:50:54 +0200
committerDan McGee <dan@archlinux.org>2010-10-14 00:50:54 +0200
commit6eedf06fcc224648155bc5253d6fe1975be8da00 (patch)
tree98ab83ec4927766ba88f2bbf819a59a5d8cb9f35 /configure.ac
parenta7dc3875f15f9600e011c313c8846de6af3a2c8c (diff)
downloadpacman-6eedf06fcc224648155bc5253d6fe1975be8da00.tar.gz
pacman-6eedf06fcc224648155bc5253d6fe1975be8da00.tar.xz
Fix bash shell location check
BASH is defined when you are actually using bash during configure, which sucks because it ends up being '/bin/sh', messing up all of our scripts. Change the name of the variable we use in configure, and also ensure we get a full path to the executable by using AC_PATH_PROGS rather than AC_CHECK_PROGS. Finally, change the variable name everywhere we use it. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 115aeb15..6f601f4b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,7 +127,7 @@ AC_PROG_LN_S
AC_PROG_MAKE_SET
AC_PROG_LIBTOOL
AC_CHECK_PROGS([PYTHON], [python2.7 python2.6 python2.5 python2 python], [false])
-AC_CHECK_PROGS([BASH], [bash bash4 bash3], [false])
+AC_PATH_PROGS([BASH_SHELL], [bash bash4 bash3], [false])
# find installed gettext
AM_GNU_GETTEXT([external])