summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-11-20 18:38:24 +0100
committerDan McGee <dan@archlinux.org>2007-12-21 18:05:38 +0100
commit741fa316038eb0307e4aaffcac05eaa36303ead9 (patch)
tree2f80987844a4a8ec814abf5f7bb5d3de492f2c0d /configure.ac
parentc0845db8f7cc3f0fbf9bfadbdbb30b0acc96c242 (diff)
downloadpacman-741fa316038eb0307e4aaffcac05eaa36303ead9.tar.gz
pacman-741fa316038eb0307e4aaffcac05eaa36303ead9.tar.xz
Remove abs from the pacman repository
abs has always been an Arch Linux specific tool, and although it is used primarily by pacman and makepkg, it should not be included with a distro- agnostic tarball. In addition, maintenance of the script would be better outside of pacman and would allow for more frequent updates. This also facilitates our move away from a cvsup/csup dependent tool for syncing PKGBUILDs. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 1 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 9a5f3b3e..bed26cfd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -113,11 +113,6 @@ AC_ARG_ENABLE(debug,
AC_HELP_STRING([--enable-debug], [enable debugging support]),
[debug=$enableval], [debug=no])
-# Help line for abs
-AC_ARG_ENABLE(abs,
- AC_HELP_STRING([--disable-abs], [do not include Arch Linux Build System script]),
- [includeabs=$enableval], [includeabs=yes])
-
# Help line for pacman.static
AC_ARG_ENABLE(pacman-static,
AC_HELP_STRING([--disable-pacman-static], [do not build static version of pacman]),
@@ -273,17 +268,7 @@ else
CFLAGS="$CFLAGS -Wall"
fi
-# Enable or disable inclusion of abs script
-AC_MSG_CHECKING(for inclusion of abs script)
-if test "x$includeabs" = "xyes" ; then
- AC_MSG_RESULT(yes)
- AC_DEFINE([INCLUDE_ABS], , [Include abs script])
-else
- AC_MSG_RESULT(no)
-fi
-AM_CONDITIONAL(INCLUDE_ABS, test "x$includeabs" = "xyes")
-
-# Enable or disable inclusion of abs script
+# Enable or disable inclusion of pacman.static
AC_MSG_CHECKING(whether to build pacman.static)
if test "x$pacmanstatic" = "xyes" ; then
AC_MSG_RESULT(yes)
@@ -315,7 +300,6 @@ scripts/Makefile
doc/Makefile
etc/Makefile
etc/pacman.d/Makefile
-etc/abs/Makefile
po/Makefile.in
pactest/Makefile
contrib/Makefile
@@ -355,7 +339,6 @@ pacman_display_version:
Doxygen support : ${usedoxygen}
Asciidoc support : ${useasciidoc}
debug support : ${debug}
- include abs : ${includeabs}
build pacman.static : ${pacmanstatic}
"