summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2012-03-31 05:26:32 +0200
committerDave Reisner <dreisner@archlinux.org>2012-04-09 04:28:45 +0200
commit793eff37047dbceedaf3443311bc826566685181 (patch)
treed55886e67e13f347e483d0c30dd005f1aaee1fac /configure.ac
parent7fcb445f35d70d6dd4fa14e9d7b5de35625b0811 (diff)
downloadpacman-793eff37047dbceedaf3443311bc826566685181.tar.gz
pacman-793eff37047dbceedaf3443311bc826566685181.tar.xz
buildsys: define warning CFLAGS in separate var
Continue the trend of not touching the environment CFLAGS, ensuring that the user always has the final say. Signed-off-by: Dave Reisner <dreisner@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 13dddc61..3c6df0db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -350,10 +350,10 @@ if test "x$debug" = "xyes" ; then
GCC_STACK_PROTECT_LIB
GCC_STACK_PROTECT_CC
GCC_FORTIFY_SOURCE_CC
- CFLAGS="$CFLAGS -g -Wall -Werror"
+ WARNING_CFLAGS="-g -Wall -Werror"
else
AC_MSG_RESULT(no)
- CFLAGS="$CFLAGS -Wall"
+ WARNING_CFLAGS="-Wall"
fi
# Enable or disable use of git version in pacman version string
@@ -424,7 +424,7 @@ ${PACKAGE_NAME}:
compiler : ${CC}
preprocessor flags : ${CPPFLAGS}
- compiler flags : ${CFLAGS}
+ compiler flags : ${WARNING_CFLAGS} ${CFLAGS}
defines : ${DEFS}
library flags : ${LIBS} ${LIBSSL_LIBS} ${LIBARCHIVE_LIBS} ${LIBCURL_LIBS} ${GPGME_LIBS}
linker flags : ${LDFLAGS}