summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2010-12-17 19:48:09 +0100
committerDan McGee <dan@archlinux.org>2010-12-30 02:24:13 +0100
commit81dd9d3ebc3eca04fade4df4689c53d1d11c5f19 (patch)
tree443566a22e9787f2cfac44a9eb2e59631ab118d1 /configure.ac
parentfcc09bd7e35766a5f025282491501824ee11cf27 (diff)
downloadpacman-81dd9d3ebc3eca04fade4df4689c53d1d11c5f19.tar.gz
pacman-81dd9d3ebc3eca04fade4df4689c53d1d11c5f19.tar.xz
Detect undefined PATH_MAX
POSIX does not require PATH_MAX be defined when there is not actual limit to its value. This affects HURD based systems. Work around this by defining PATH_MAX to 4096 (as on Linux) when this is not defined. Also, clean up inclusions of limits.h and remove autoconf check for this header as we do not use macro shields for its inclusion anyway. Signed-off-by: Allan McRae <allan@archlinux.org> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 747c8b75..11b6b11a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -172,7 +172,7 @@ AS_IF([test "x$with_fetch" != "xno"],
AM_CONDITIONAL([HAVE_LIBFETCH], [test "x$ac_cv_lib_fetch_fetchParseURL" = "xyes"])
# Checks for header files.
-AC_CHECK_HEADERS([fcntl.h glob.h libintl.h limits.h locale.h mntent.h string.h strings.h \
+AC_CHECK_HEADERS([fcntl.h glob.h libintl.h locale.h mntent.h string.h strings.h \
sys/ioctl.h sys/mount.h sys/param.h sys/statvfs.h sys/syslimits.h \
sys/time.h sys/types.h sys/ucred.h syslog.h wchar.h])
@@ -185,6 +185,7 @@ AC_TYPE_SIZE_T
AC_STRUCT_TM
AC_TYPE_UID_T
AC_STRUCT_DIRENT_D_TYPE
+PATH_MAX_DEFINED
# Checks for library functions.
AC_FUNC_FORK