summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2008-12-27 07:35:06 +0100
committerDan McGee <dan@archlinux.org>2009-01-03 07:13:54 +0100
commit8f26bb9052fe1bb131d2062da4fcd917fc9ad4da (patch)
tree905de28caff6306085d909b3b2c1ed2477f318ce /configure.ac
parent9a7f68317aa652cbc89e7fa69381d6239a63a6e7 (diff)
downloadpacman-8f26bb9052fe1bb131d2062da4fcd917fc9ad4da.tar.gz
pacman-8f26bb9052fe1bb131d2062da4fcd917fc9ad4da.tar.xz
makepkg: move BUILDSCRIPT from makepkg.conf
Commit 4b183bf9 moved makepkg.conf sourcing to after the parsing of options, breaking the -p option and --help output. The solution is to move BUILDSCRIPT out of makepkg.conf. This patch moves the definition BUILDSCRIPT back to makepkg itself and adds configure option to allow easy changing of this value during build time. Signed-off-by: Allan McRae <allan@archlinux.org> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c7841b80..5f1a1534 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,6 +88,11 @@ AC_ARG_WITH(db-ext,
AS_HELP_STRING([--with-db-ext=ext], [set the file extension used by the database]),
[DBEXT=$withval], [DBEXT=.db.tar.gz])
+# Help line for buildscript filename
+AC_ARG_WITH(buildscript,
+ AS_HELP_STRING([--with-buildscript=name], [set the build script name used by makepkg]),
+ [BUILDSCRIPT=$withval], [BUILDSCRIPT=PKGBUILD])
+
# Help line for libdownload/libfetch
AC_ARG_ENABLE(internal-download,
AS_HELP_STRING([--disable-internal-download], [do not build with libdownload/libfetch support]),
@@ -314,6 +319,9 @@ AC_DEFINE_UNQUOTED([SRCEXT], "$SRCEXT", [The file extension used by pacman sourc
# Set database file extension
AC_SUBST(DBEXT)
AC_DEFINE_UNQUOTED([DBEXT], "$DBEXT", [The file extension used by pacman databases])
+# Set makepkg build script name
+AC_SUBST(BUILDSCRIPT)
+AC_DEFINE_UNQUOTED([BUILDSCRIPT], "$BUILDSCRIPT", [The build script name used by makepkg])
# Configuration files
AC_CONFIG_FILES([
@@ -362,6 +370,7 @@ ${PACKAGE_NAME}:
package extension : ${PKGEXT}
source pkg extension : ${SRCEXT}
database extension : ${DBEXT}
+ build script name : ${BUILDSCRIPT}
Compilation options:
Run make in doc/ dir : ${wantdoc}