summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2007-11-01 03:30:09 +0100
committerDan McGee <dan@archlinux.org>2007-11-04 17:42:07 +0100
commit8feccaed7861010caefa4f7b9824a612a78e3043 (patch)
tree207bea0248d1b3d48092150e80cb3b983103a658 /configure.ac
parent288dd54982b85f6feae7d41faf91a531d9f71085 (diff)
downloadpacman-8feccaed7861010caefa4f7b9824a612a78e3043.tar.gz
pacman-8feccaed7861010caefa4f7b9824a612a78e3043.tar.xz
Use an autoconf macro to see if -fstack-protector is available
Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 366eefa9..d93cea84 100644
--- a/configure.ac
+++ b/configure.ac
@@ -254,8 +254,10 @@ if test "x$debug" = "xyes" ; then
AC_DEFINE([PACMAN_DEBUG], , [Enable debug code])
# Check for mcheck
AC_CHECK_HEADERS([mcheck.h])
-
- CFLAGS="$CFLAGS -g -Wall -Werror -fstack-protector-all"
+ # Check for -fstack-protector availability
+ GCC_STACK_PROTECT_LIB
+ GCC_STACK_PROTECT_CC
+ CFLAGS="$CFLAGS -Wall -Werror"
else
AC_MSG_RESULT(no)
CFLAGS="$CFLAGS -Wall"