summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2010-09-27 08:04:10 +0200
committerAllan McRae <allan@archlinux.org>2010-09-27 08:06:52 +0200
commit900605912b32d08ece7a3e80e4c6b258485676b7 (patch)
tree6b73de46b1b37398409200d2da4b0902fe0220a1 /configure.ac
parent28c662e7a422314475cca61663695dd31fd86546 (diff)
downloadpacman-900605912b32d08ece7a3e80e4c6b258485676b7.tar.gz
pacman-900605912b32d08ece7a3e80e4c6b258485676b7.tar.xz
Add FORTIFY_SOURCE support
Adds a check for the minimum mainline GCC version for FORTIFY_SOURCE support and enables -D_FORTIFY_SOURCE=2 by default when building with --enable-debug. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b4570f58..76e36c8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -316,6 +316,7 @@ if test "x$debug" = "xyes" ; then
# Check for -fstack-protector availability
GCC_STACK_PROTECT_LIB
GCC_STACK_PROTECT_CC
+ GCC_FORTIFY_SOURCE_CC
CFLAGS="$CFLAGS -g -Wall -Werror"
else
AC_MSG_RESULT(no)