summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Reisner <d@falconindy.com>2011-03-18 16:03:28 +0100
committerDan McGee <dan@archlinux.org>2011-03-28 16:04:15 +0200
commit9477abc3591905a20acbfe7b8ce7832617d72701 (patch)
treef5b63ec70295739b6ad5d8ec048d1437ea88da8f /configure.ac
parente8069cfc3def97f564f5e4a4301e43de2a6a9b67 (diff)
downloadpacman-9477abc3591905a20acbfe7b8ce7832617d72701.tar.gz
pacman-9477abc3591905a20acbfe7b8ce7832617d72701.tar.xz
pacman/util: flush terminal input before reading response
Addresses FS#20538 Signed-off-by: Dave Reisner <d@falconindy.com> Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 87330afc..32993029 100644
--- a/configure.ac
+++ b/configure.ac
@@ -154,7 +154,8 @@ AC_CHECK_LIB([gpgme], [gpgme_check_version], ,
# Checks for header files.
AC_CHECK_HEADERS([fcntl.h glob.h libintl.h locale.h mntent.h string.h \
sys/ioctl.h sys/mount.h sys/param.h sys/statvfs.h \
- sys/time.h sys/types.h sys/ucred.h syslog.h wchar.h])
+ sys/time.h sys/types.h sys/ucred.h syslog.h termios.h \
+ wchar.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_C_INLINE
@@ -173,7 +174,7 @@ AC_FUNC_GETMNTENT
AC_FUNC_LSTAT_FOLLOWS_SLASHED_SYMLINK
AC_FUNC_MKTIME
AC_CHECK_FUNCS([geteuid getmntinfo realpath regcomp strcasecmp \
- strndup strrchr strsep swprintf \
+ strndup strrchr strsep swprintf tcflush \
wcwidth uname])
# For the diskspace code
FS_STATS_TYPE