summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2008-07-16 02:05:24 +0200
committerDan McGee <dan@archlinux.org>2008-07-16 02:05:24 +0200
commit95995ae93f90faab2f4c9fe59ea95167d20c88de (patch)
tree112a033461b4be9686abdd51a1a357eae9a5f136 /configure.ac
parent874190827676e3a974e8c5fef6c51b9e9d6b60fa (diff)
downloadpacman-95995ae93f90faab2f4c9fe59ea95167d20c88de.tar.gz
pacman-95995ae93f90faab2f4c9fe59ea95167d20c88de.tar.xz
Remove pacman.static build from build files
This presents plenty of problems on OSes besides Linux, and even on Linux when the libtool file for libarchive isn't present. The static build isn't all that useful anyway as missing something such as glibc will still leave you unable to run the pacman.static binary. Remove it from the formal build process. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 0 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index ab5a3744..b4b6a566 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,11 +119,6 @@ AC_ARG_ENABLE(git-version,
[enable use of git version in version string if available]),
[wantgitver=$enableval], [wantgitver=no])
-# Help line for pacman.static
-AC_ARG_ENABLE(pacman-static,
- AS_HELP_STRING([--disable-pacman-static], [do not build static version of pacman]),
- [pacmanstatic=$enableval], [pacmanstatic=yes])
-
# Checks for programs.
AC_PROG_AWK
AC_PROG_CC_C99
@@ -324,16 +319,6 @@ else
fi
AM_CONDITIONAL(USE_GIT_VERSION, test "x$usegitver" = "xyes")
-# Enable or disable inclusion of pacman.static
-AC_MSG_CHECKING(whether to build pacman.static)
-if test "x$pacmanstatic" = "xyes" ; then
- AC_MSG_RESULT(yes)
- AC_DEFINE([INCLUDE_PACMAN_STATIC], , [Build pacman.static])
-else
- AC_MSG_RESULT(no)
-fi
-AM_CONDITIONAL(INCLUDE_PACMAN_STATIC, test "x$pacmanstatic" = "xyes")
-
# Set root directory
AC_SUBST(ROOTDIR)
# Set package file extension
@@ -398,7 +383,6 @@ ${PACKAGE_NAME}:
Doxygen support : ${usedoxygen}
Asciidoc support : ${useasciidoc}
debug support : ${debug}
- build pacman.static : ${pacmanstatic}
"
# vim:set ts=2 sw=2 noet: